Marvell and others ATA kext for Leopard



Hi! Here is driver for marvell(for now) ata and sata chipsets

They are present on some motherboards as secondary ata controller but are unsupported with tiger and leopard

So I did a try to insert pci id`s into AppleVIAATA.kext with known and usefull chipsets

  • 0x611111ab - used at P5K-SE motherboard (Marvell 88se6111)
  • 0x614511ab - used at Intel D975XBX2 and ASUS P5WDG2 WS Professional motherboard (Marvell 88se6145)

Installation

  1. backup original AppleVIAATA.kext at /System/Library/Extensions
  2. copy attached kext into /System/Library/Extensions
  3. start Terminal and run: sudo chown -Rv root:wheel /System/Library/Extensions
  4. remove /System/Library/Extensions.mkext and reboot

Post bugs here

Trackback URL for this post:

http://itua.name/en/trackback/73
Share this
AttachmentSize
AppleVIAATA6111_6145.kext_.zip134.33 KB
AppleVIAATA_SATA_only_version.kext_.zip136.44 KB

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
precision's picture

I get the following when

I get the following when installing this under 10.5.5

Oct  1 17:48:34 pabst kernel[0]: Can't unload com.apple.driver.AppleVIAATA due to -
Oct  1 17:48:34 pabst kernel[0]: com.apple.driver.AppleVIAATA: AppleVIAATARoot has 1 instance(s)
Oct  1 17:48:34 pabst kernel[0]: com.apple.driver.AppleVIAATA: AppleVIAATAChannel has 2 instance(s)

podarok's picture

gm... May be 10.5.5 has

gm... May be 10.5.5 has another driver instance for it or You didn`t make repair permissions

precision's picture

A quick grep in

A quick grep in /System/Library/Extensions didn't return anything matching 614511ab, and permissions seem fine..

# cd /System/Library/Extensions && grep -ril 614511ab *
AppleVIAATA.kext/Contents/Info.plist
#
podarok's picture

try to delete from Info.plist

try to delete from Info.plist full dictionary VIA PATA Marvell and use only VIA PATA Marvell2

May be there is conflict between PATA and SATA dictionaries
podarok's picture

uploaded modified SATA only

uploaded modified SATA only version for precision

precision's picture

Still no love.  Just like

Still no love.  Just like before I see the driver is loaded in ioreg and it detects 2 channels, but none of the drives attached to the channels are accessible.  Another note, this controller has 4 sata ports, not sure if it's using a port multiplier or not.

    | |   +-o PEX4@1C,4  <class IOPCIDevice, registered, matched, active, busy 0, retain 9>
    | |   | +-o IOPCI2PCIBridge  <class IOPCI2PCIBridge, registered, matched, active, busy 0, retain 7>
    | |   |   +-o pci11ab,6145@0  <class IOPCIDevice, registered, matched, active, busy 0, retain 10>
    | |   |     +-o AppleVIAATARoot  <class AppleVIAATARoot, !registered, !matched, active, busy 0, retain 6>
    | |   |       +-o CHN0@0  <class AppleVIAATAChannel, registered, matched, active, busy 0, retain 6>
    | |   |       +-o CHN1@1  <class AppleVIAATAChannel, registered, matched, active, busy 0, retain 6>
podarok's picture

try to set it into nonAHCI

try to set it into nonAHCI mode in bios or maybe in some compatible mode

precision's picture

I tried setting it to IDE vs

I tried setting it to IDE vs AHCI and it didn't seem to make much difference at all.  :(

podarok's picture

so it is that moment, when

so it is that moment, when VIA driver didn`t support Marvell chipset 8(

precision's picture

Hrm, it seems that 10.5.4 is

Hrm, it seems that 10.5.4 is when this all changed.  I'll try to snag the older driver from a 10.5.2 machine and see if it works or if it is some other interaction.

podarok_incognito's picture

I`ll waiting for Your result

I`ll waiting for Your result but I think that problem not with Leo Version.
Try ti insert info.plist from my kext into last from 10.5.4 or 10.5.5

precision's picture

I already tried just merging

I already tried just merging your info.plist info into the latest 10.5.5 driver and still no love.

podarok's picture

Try look into System Profiler

Try look into System Profiler and check AppleVIAATA.ext loading path - may be You have to different instances in Your system and they make conflicts for You

precision's picture

Nope, just one instance.

Nope, just one instance. Seems they broke this driver/card somehow in 10.5.4+.

podarok's picture

This driver is for VIA

This driver is for VIA chipsets 8))) not for Marvell
So nothing broken - just unsupported 8))) even via my smart hack
Need trying make support via another nonVIA-based chipset driver - may be it will work..

luong's picture

what will I do with

what will I do with motherboad ASUS P5KSE/EPU?
- Install on other MB (support) then fix kext and... move HDD to this Motherboard!!!!
I think it work!

Duy's picture

I've install all driver under

I've install all driver under my 10.5.5. Nothing worked!

podarok's picture

What the MB model?

What model of MB and what kind of marvell chipset ?

Duy's picture

My model is P5K SE - EPU with

My model is P5K SE - EPU with Marvell 88SE6111 , under iATKOS v5i

Duy's picture

OMG, I did it. I reinstalled

OMG, I did it. I reinstalled my hackintosh and I chose 9.2.0 TOH kernel instead of 9.5.0 (not vanilla) and it worked. I think 9.5.0 kernel in iatkos v5i has error.

podarok_'s picture

tohkernel vs vanilla

Woops..
I always thought anyone know that all hackintosh mods have to make with non-original kernel.
And after that we can try to install vanilla.

Malay's picture

Appleviaata.kext not loading at start

Check system profiler doesn't seem to be loaded and also have a marvel 614X chipset which should be very similiar
I'll try changing the vendor id or something but do you know where the original one was located?
thx

podarok's picture

ioreg pcidump?

Try looking into full pci dump for full vendor and ID information
If they are similar to posted here - try to install it via kexthelper that kills all instances of previous kext 8)

boltown's picture

Will this work for marvell

Will this work for marvell sataII on Intel 975xbx2 mobo?
Thanks for your help,
boltown

podarok_'s picture

yup

when pci id`s are identical - yes it is!
Otherwise - You have to add it to info.plist inside kext and reinstall it via kexthelper -

Donald's picture

Please help me

I am using Intel D975XBX2, installed Mac os x 10.7.2 and upgraded to 10.2.4 but could not access any drive connected to Marvell 88SE6145. I tried these attached files but still these are not detected. Please guide me to bring it to work. If it won't possible than also please let me know that. Than I have to change the mother board.

Thanking you
With regards
Donald

Syndicate content Syndicate content

Propeople Expert

Партнери

Recent comments

експерименти

Rambler's Top100